Associació Guifi.net Sant Feliu de Codines

Category Archives: Guifi.net

La Fundació guifi.net rep de part de la CE el reconeixement com a un dels millors 5 projectes de Banda Ampla Europeus del 2015

La Fundació guifi.net ha rebut aquesta tarda a Brussel·les de la mà del Comissari Günter H. Oettinger per a l’Economia i Societat Digital de la Comissió Europea, el premi com a millor iniciativa per la Banda Ampla de nova generació del 2015 en la categoria de “models innovadors en finançament / models econòmics i inversió” com a reconeixement al model desenvolupat i al considerar-lo com a model de referència per a la inspiració de molts altres projectes de banda ampla de nova generació a Europa.

Demà, també a Brussel·les, es presentarà la iniciativa i el model econòmic que aquesta iniciativa desenvolupa en el marc de la jornada “B-Day: Broadband 2020 and Beyond” organitzada per la Comissió Europea.

Des de la Fundació guifi.net manifestem el nostre agraïment a la Comissió Europea i al jurat que ha avaluat les propostes, per haver-nos considerat mereixedors d’un reconeixement del més alt nivell europeu com aquest.

És un orgull que una iniciativa col·lectiva que s’empeny des de la base, amb la participació de la ciutadania i el voluntariat, de petites i mitjanes empreses al territori i amb la col·laboració de diverses administracions locals, es consideri com un exemple de model econòmic innovador a seguir per aconseguir els objectius Europeus per al 2020 per la banda ampla ultraràpida de nova generació.

El mèrit d’aquest reconeixement és, per tant, de tot el col·lectiu de participants d’aquest model d’economia col·laborativa mitjançant el qual es desplega una Xarxa de Comuns per a l’accés a Internet.

La xarxa de telecomunicacions guifi.net va començar-se a desenvolupar al 2004, com a iniciativa ciutadana que mitjançant enllaços sense fils aconseguia fer arribar l’accés a Internet on no era possible tenir-lo de cap altra manera. Des d’aquell moment la infraestructura de xarxa no ha parat de créixer, havent incorporat, en els darrers anys, trams de xarxa amb fibra òptica i desenvolupat el model econòmic basat em la gestió dels Comuns i la economia col·laborativa aplicant els principis de la premi Nobel d’Economia 2009, la doctora Elinor Ostrom. El resultat és l’habilitació de professionals i petites empreses vinculades al territori per posar en valor la proximitat i oferir uns serveis competitius en cost i qualitat als que puguin oferir els operadors que utilitzen models estrictament privats basats en el domini de la infraestructura.

Com a fites remarcables aconseguides en els darrers anys destaquen, entre d’altres:

  • Fer possible que prop de cent mil persones accedeixin a Internet a través de la Xarxa de Comuns des d’unes 30.000 llars i ubicacions diverses, principalment a Catalunya, però també en altres llocs de la Península Ibèrica, i col·laborant amb iniciatives similars arreu del món.
  • Tenir en funcionament 18 punts de presència amb fibra òptica repartits en diverses comarques de Catalunya
  • Haver desplegat amb èxit fibra òptica fins a les llars, no només a zones urbanes i industrials, sinó també a entorns rurals a on s’han connectant granges i cases de pagès, i haver demostrat, d’aquesta manera, que en aquests llocs la fibra òptica no només que és viable, sinó que també és la tecnologia més idònia per connectar-los a Internet
  • Aconseguir que les comarques de Catalunya on la Xarxa de Comuns té més presència siguin les que presenten un índex més alt d’adopció de la banda ampla a les llars, segons dades d’IDESCAT, a on destaca la comarca d’Osona com la primera comarca catalana que ha assolit i superat els nivells de la mitjana europea
  • El compromís inequívoc amb la qualitat de l’accés a Internet al territori, el qual es materialitza amb la posada en funcionament de punts d’intercanvi de trànsit de proximitat. Fruit d’aquest compromís, guifi.net s’ha convertit en poc temps en un dels majors intercanviadors de trànsit al punt neutre de Catalunya (CATNIX)
  • Participació activa a consorcis i projectes de recerca nacionals i internacionals dels àmbits tecnològic i socioeconòmic.

Tot això, desenvolupant un model econòmic no especulatiu, no discriminatori, basat en l’economia col·laborativa del Bé Comú, la transparència i la sostenibilitat, respectuós amb el marc jurídic europeu, creant noves formules de col·laboració publicoprivada, generador fins a la data d’avui de noves inversions per valor de més de 6 milions d’euros, amb un volum recurrent directe de més de dos milions d’euros anuals i generant ocupació de qualitat i proximitat.

La Fundació privada per a la Xarxa Oberta, Lliure i Neutral, guifi.net és una organització no governamental, sense obediència política i sense ànim de lucre ni conflicte d’interessos amb els participants que promou i gestiona la Xarxa de Comuns.

Podeu contactar amb la fundació escrivint a fundacio@guifi.net.

Evolució guifinet Sant Feliu

El 2014 ha sigut un bon any per la comunitat de Guifi.net a Sant Feliu. La xarxa ha crescut i l’associació ha crescut fins als 46 nodes operatius (23 més en projectats) i 42 socis (a mi m’agrada també dir 42 cases) connectades a la xarxa.

Com sabeu, la gestió de la xarxa també ha patit canvis aquest any. Fins a mitjans de 2014 en David s’ocupava de forma “professional” (per dir-ho d’alguna manera) del manteniment de la xarxa, i ara ho fa al seu temps lliure.

Això em porta a parlar de la gestió de la xarxa i de la seva disponibilitat. Com sabeu, a l’Associació no donem garantia de servei. És a dir, pensem, muntem i reparem tot el possible perquè la xarxa funcioni bé, però no ens comprometem a que funcioni 24h els 365dies de l’any, sobretot perquè no hi ha una empresa o autònom a darrera que en tregui benefici i s’hi dediqui.

Fins ara, els principals problemes han vingut donats per:

1.- Falta de llum a l’AjVell quan des de l’Escola de Música connectaven molts aparells a la xarxa elèctrica (a l’hivern sobretot). Fins la setmana passada, compartíem part de la xarxa (i un diferencial concret, que era el que saltava). Ara ja som independents (com a mínim des d’aquest punt conflictiu) i des de llavors no ha tornat a haver-hi problemes.

2.- Caigudes puntuals de llum per causa major al SN de Solanes: Allà el punt de corrent és compartit amb un repetidor de la Policia Local, que es va espatllar i feia saltar el diferencial constantment; o durant el temporal de ventades, on va quedar tota la urbanització sense subministrament. Tenim previst posar un SAI per evitar les petits talls que pugui haver i acabar de reduir els problemes en aquest punt (que d’altra banda son molt puntuals)

3.- El tercer, tot i no ser un problema tècnic ni elèctric, és el més important segurament, i és que el temps de reacció augmenta en tant que en David o jo, qui normalment som els que anem a resoldre el problema, no ens adonem de que falla fins que algun soci ens dóna l’avís (ja sigui per mail o per whatsapp).

Pel que fa a les sortides, aquí és on hi ha hagut i hi haurà canvis substancials. Durant el 2014 hem passat a oferir connectivitat directa als socis de l’Associació amb una quota més alta (100€ l’any), mantenint però en tot moment la navegació bàsica per proxy amb la quota de 50€ l’any. Per tant, fins ara tenim:

– Proxy1: Situat a l’Ajuntament, accedeix a internet per una ADSL de l’Ajuntament de 10Mb/1Mb (pujada/baixada)
– Proxy2: Situat a Ona Codinenca, accedeix a internet per una ADSL de l’ajuntament de 10Mb/1Mb (pujada/baixada)
– Proxy3: Situat a l’antic Ajuntament (AjVell), accedeix a internet per una ADSL de l’Associació de 30Mb/3Mb (pujada/baixada)
– VPNs: Connexions directe de les nodes dels socis als routers de AjVell per accedir sense proxy a internet.

A partir d’ara, amb el nou projecte de fibra, l’Ajuntament de Sant Feliu donarà de baixa les ADSL que té repartides als equipaments municipals, per passar a sortir en tots els equipaments per una sortida de 20Mb/20Mb (20Megues simètrics, tant de pujada com de baixada). Això què implica? Dons d’entrada que dels dos proxys que tenim sortint per les ADSLs de l’Ajuntament, només en calgui un, ja que tant el proxy1 com el proxy2 tindrien la mateixa sortida. El que mantinguem, a més, haurem de veure de quin ample de banda (dels 20 simètrics) pot disposar, doncs evidentment no seran tots, ja que cal garantir el funcionament de la connexió a internet per els seus usos principals (ajuntament, entitats, etcètera).

Estem mirant també amb l’Ajuntament de poder contractar una línia a nom de l’Associació per no haver de fer servir la de l’Ajuntament, i que aquesta es pugui pagar amb la subvenció d’activitat que l’Ajuntament dóna a totes les entitats del poble. D’altra banda, també hi ha mig pendent la possibilitat de fer ús directe de la xarxa de fibra òptica per part de la Fundació guifinet i els seus operadors. Us informaré de com avancen aquests dos punts.

De cara al 2015, aquests últims canvis que us he explicat no comportaran excessius canvis als usuaris (bàsicament el poder triar entre 2 sortides a internet (de Sant Feliu) en comptes de 3 com fins ara). Us recordo que hi ha més proxys disponibles a la xarxa de guifi.net, així com serveis que no requereixen connexió a internet per fer-los servir.

No vull acabar sense comentar per sobre el tema econòmic. Ara mateix paguem els rebuts de l’ADSL sense problemes i podem fer front a petites reparacions de material o millores (poca cosa, però es pot afrontar). Ens falta passar la quota del 4t trimestre del 2014 encara, per tant als que la teniu domiciliada us arribarà en breu el càrrec.

Bé, si heu arribat fins aquí us dono les gràcies! I com sempre, estic a la vostra disposició per qualsevol aclariment.

Pau Ibars – President de l’Associació Guifi.net Sant Feliu

Localitzar una incidencia a la xarxa

La conexio a Internet a traves de la xarxa guifi.net esta formada per diversos elements.
Read More

Exportar usuaris pptp entre dispositius Mikrotik

En un escenari on tenim un servidor VPN que volem migrar a un altre dispositiu, tenim una opcio molt mes rapida que tornar a fer els usuaris manualment.
Read More

Desplegament Xarxa Mesh a Sant Feliu (en proves)

L’esquema que hem fet servir fins ara al poble, ha sigut el mode de xarxa en infraestructura (els nodes s’intercomuniquen mitjançant un punt d’acces).
Amb ubicacions com Solanes, que es veu des de qualsevol indret de Sant Feliu, dona molt bon resultat.
Pero a urbanitzacions envoltades d’arbres, i amb diferents alçades, es donen situacions en que nodes separats 200m no es poden conectar.
Aixo ho resol altre mode de fer xarxa: mesh.
Read More

Com canviar de proxy amb Firefox

Com que el tema de com canviar de proxy es bastant recurrent, possem aqui un pas a pas del que hem de fer per configurar el navegador Firefox per sortir per qualsevol dels proxies de Sant Feliu de Codines.
Read More

Taller basic de xarxes

Per tal de que els usuaris de la xarxa guifi.net tinguin una mica mes d’autonomia per resoldre questions basiques com canviar de proxy, i entendre una mica millor que significa ser usuari de guifi.net i conceptes imprescindibles de les xarxes en general, i de guifi en particular, propossem un primer taller pel proper divendres 18 de juliol a les 17h a Can Buixo (CENTRE SOCIAL MARIA ROCA-UMBERT, Ctra. St. Llorenç, 6, al costat del Condis per la part de dalt).

El contingut del taller seria:

·Que es una IP?
·Que es un proxy?
·Instalar guifiproxy a Mozilla Firefox
·Resolucio de dubtes
·Webs basiques de referencia

Si voleu fer practiques configurant algun dispositiu, podeu portar-lo ja que a Can Buixo tenim acces a guifi.net.

Esperem la vostra assistencia.

Resultats de l’enquesta de satisfacció amb el servei de guifi.net

Fa unes setmanes vam fer una enquesta anonima als socis i usuaris de la xarxa de Sant Feliu.
Aqui podeu veure l’informe dels resultats.

resultados_encuesta_satisfaccion_guifi.net

Tot i la baixa participacio (un terç del total d’usuaris) es poden extreure algunes conclusions:

·El boca-orella es el mitja que dona mes difusio a la xarxa
·La majoria (75%) d’usuaris fan servir la xarxa diariament
·Hi ha un 60% d’usuaris que es troba satisfet o molt satisfet, i un 40% poc o gens satisfet. Aquesta dada es bastant preocupant, i el que indica es que s’ha de continuar treballant per oferir un millor servei.
·La meitat dels usuaris troben que la seva conexio es mes o menys igual que amb altres proveidors, i un 40% troba que es pitjor. Aquest alt resultat d’insatisfaccio es degut principalment al fet d’haver de fer servir proxy per conectar a Internet. Ara ja hi ha una alternativa lliure per qui vulgui un servei de conexio directa a la xarxa: Lliure.net (encara que un 80% indica que continuaria amb la conexio actual, aixo indica clarament que el principal atractiu de la xarxa es que no te quotes mensuals).
·Sobre la professionalitat del servei, un 80% ens dona un aprobat (en diferents graus).
·En quant a la qualitat, un 30% pensa que es de baixa qualitat, i un 60% es mostra satisfet.
·Sobre la relacio qualitat/preu, un 90% pensa esta bastant be.
·Sobre el servei que es dona un cop feta l’instal·lacio, un 80% esta satisfet. Cal recordar al 10% que no esta satisfet que amb un servei gratuit sense quotes mensuals no es pot esperar absolutament res, si no es pagant apart els serveis.
·Sobre com esta organitzada la xarxa, un 80% esta satisfet.
·Altra dada curiosa es que el 90% d’usuaris se sent lliure de participar. Llavors la pregunta seguent hauria de ser: per que no ho feu? 🙂
·En quant a recomanar guifi.net a altres persones, un 90% ho ha fet, pero hi ha un 20% que ara no ho faria.
·Sobre la continuitat dels socis pel proper any, es probable que un 90% encara continuin.

En general, tot i que es gairebe imposible tenir tothom content, la impressio es que estem en el bon cami, pero que encara s’ha de treballar molt per millorar.

Moltes gracies als que vau participar, i a tots els usuaris en general que feu gran guifi.net!!!

Configuració de QoS a la xarxa de Sant Feliu

A la xarxa guifi de Sant Feliu tenim definides, als dispositius d’enrutament Mikrotik, una serie de regles de QoS, per tal d’aprofitar al maxim l’ample de banda i poder donar una conexio de qualitat a tots els usuaris.

Marquem i assignem prioritats i velocitats al trafic, seguint el seguent esquema:

Interactive. Prioritat màxima (1), 30M. Tipus de tràfic: ping, TCP ACK, TCP SYN, DNS, VoIP.
Fast. Prioritat 2, 10M. Tipus de tràfic: SSH, Winbox, RDP.
Internet. Prioritat 3, 30M. Tipus de tràfic: Proxy, VPN, tincVPN.
Guifi. Prioritat 4, 40M. Tipus de tràfic: Other (tràfic que no es de cap de les altres categories).
Bulk. Prioritat 7, 10M. Tipus de tràfic: FTP, P2P.

Les regles implementades son aquestes:

/ip firewall mangle
add action=mark-packet chain=postrouting comment="wlan2 - FTP" \
connection-type=ftp new-packet-mark=wlan2-bulk out-interface=wlan2 \
passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment="wlan4 - FTP" \
connection-type=ftp new-packet-mark=wlan4-bulk out-interface=wlan4 \
passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment="wlan2 - P2P" \
new-packet-mark=wlan2-bulk out-interface=wlan2 p2p=all-p2p passthrough=no
add action=mark-packet chain=postrouting comment="wlan4 - P2P" \
new-packet-mark=wlan4-bulk out-interface=wlan4 p2p=all-p2p passthrough=no
add action=mark-packet chain=postrouting comment="wlan2 - Proxy" \
new-packet-mark=wlan2-internet out-interface=wlan2 passthrough=no \
protocol=tcp src-port=3128
add action=mark-packet chain=postrouting comment="wlan4 - Proxy" \
new-packet-mark=wlan4-internet out-interface=wlan4 passthrough=no \
protocol=tcp src-port=3128
add action=mark-packet chain=postrouting comment="wlan4 - OpenVPN" \
new-packet-mark=wlan4-internet out-interface=wlan4 passthrough=no \
protocol=tcp src-port=1194-1196
add action=mark-packet chain=postrouting comment="wlan2 - tincVPN" \
new-packet-mark=wlan2-internet out-interface=wlan2 passthrough=no \
protocol=tcp src-port=655
add action=mark-packet chain=postrouting comment="wlan4 - tincVPN" \
new-packet-mark=wlan4-internet out-interface=wlan4 passthrough=no \
protocol=tcp src-port=655
add action=mark-packet chain=postrouting comment="wlan2 - ping" \
new-packet-mark=wlan2-interactive out-interface=wlan2 passthrough=no \
protocol=icmp
add action=mark-packet chain=postrouting comment="wlan4 - ping" \
new-packet-mark=wlan4-interactive out-interface=wlan4 passthrough=no \
protocol=icmp
add action=mark-packet chain=postrouting comment="wlan2 - TCP ACK" \
new-packet-mark=wlan2-interactive out-interface=wlan2 passthrough=no \
protocol=tcp tcp-flags=ack
add action=mark-packet chain=postrouting comment="wlan4 - TCP ACK" \
new-packet-mark=wlan4-interactive out-interface=wlan4 passthrough=no \
protocol=tcp tcp-flags=ack
add action=mark-packet chain=postrouting comment="wlan2 - TCP SYN" \
new-packet-mark=wlan2-interactive out-interface=wlan2 passthrough=no \
protocol=tcp tcp-flags=syn
add action=mark-packet chain=postrouting comment="wlan4 - TCP SYN" \
new-packet-mark=wlan4-interactive out-interface=wlan4 passthrough=no \
protocol=tcp tcp-flags=syn
add action=mark-packet chain=postrouting comment="wlan2 - DNS" \
new-packet-mark=wlan2-interactive out-interface=wlan2 passthrough=no \
protocol=udp src-port=53
add action=mark-packet chain=postrouting comment="wlan4 - DNS" \
new-packet-mark=wlan4-interactive out-interface=wlan4 passthrough=no \
protocol=udp src-port=53
add action=mark-packet chain=postrouting comment="wlan2 - SSH (out)" \
new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=no protocol=\
tcp src-port=22
add action=mark-packet chain=postrouting comment="wlan4 - SSH (out)" \
new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=no protocol=\
tcp src-port=22
add action=mark-packet chain=postrouting comment="wlan2 - SSH (in)" dst-port=\
22 new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=no \
protocol=tcp
add action=mark-packet chain=postrouting comment="wlan4 - SSH (in)" dst-port=\
22 new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=no \
protocol=tcp
add action=mark-packet chain=postrouting comment="wlan2 - WINBOX (out)" \
new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=no protocol=\
tcp src-port=8291
add action=mark-packet chain=postrouting comment="wlan4 - WINBOX (out)" \
new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=no protocol=\
tcp src-port=8291
add action=mark-packet chain=postrouting comment="wlan2 - WINBOX (in)" \
dst-port=8291 new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=\
no protocol=tcp
add action=mark-packet chain=postrouting comment="wlan4 - WINBOX (in)" \
dst-port=8291 new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=\
no protocol=tcp
add action=mark-packet chain=postrouting comment="wlan2 - RDP (in)" dst-port=\
3389 new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=no \
protocol=tcp
add action=mark-packet chain=postrouting comment="wlan4 - RDP (in)" dst-port=\
3389 new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=no \
protocol=tcp
add action=mark-packet chain=postrouting comment="wlan2 - VoIP (in)" \
dst-port=5060 new-packet-mark=wlan2-interactive out-interface=wlan2 \
passthrough=no protocol=udp
add action=mark-packet chain=postrouting comment="wlan4 - VoIP (in)" \
dst-port=5060 new-packet-mark=wlan4-interactive out-interface=wlan4 \
passthrough=no protocol=udp
add action=mark-packet chain=postrouting comment="wlan2 - VoIP (out)" \
new-packet-mark=wlan2-interactive out-interface=wlan2 passthrough=no \
protocol=udp src-port=5060
add action=mark-packet chain=postrouting comment="wlan4 - VoIP (out)" \
new-packet-mark=wlan4-interactive out-interface=wlan4 passthrough=no \
protocol=udp src-port=5060
add action=mark-packet chain=postrouting comment="wlan2 - RDP (out)" \
new-packet-mark=wlan2-fast out-interface=wlan2 passthrough=no protocol=\
tcp src-port=3389
add action=mark-packet chain=postrouting comment="wlan4 - RDP (out)" \
new-packet-mark=wlan4-fast out-interface=wlan4 passthrough=no protocol=\
tcp src-port=3389
add action=mark-packet chain=postrouting comment="wlan2 - Other" \
new-packet-mark=wlan2-guifi out-interface=wlan2 passthrough=no
add action=mark-packet chain=postrouting comment="wlan4 - Other" \
new-packet-mark=wlan4-guifi out-interface=wlan4 passthrough=no

/queue tree
add max-limit=40M name=wlan2-qdisc parent=wlan2 queue=wireless-default
add limit-at=3M max-limit=30M name=wlan2-interactive packet-mark=\
wlan2-interactive parent=wlan2-qdisc priority=1 queue=default
add limit-at=1M max-limit=10M name=wlan2-fast packet-mark=wlan2-fast parent=\
wlan2-qdisc priority=2 queue=default
add limit-at=3M max-limit=30M name=wlan2-internet packet-mark=wlan2-internet \
parent=wlan2-qdisc priority=3 queue=default
add limit-at=5M max-limit=40M name=wlan2-guifi packet-mark=wlan2-guifi \
parent=wlan2-qdisc priority=4 queue=default
add limit-at=1M max-limit=10M name=wlan2-bulk packet-mark=wlan2-bulk parent=\
wlan2-qdisc priority=7 queue=default
add max-limit=40M name=wlan4-qdisc parent=wlan4 queue=wireless-default
add limit-at=1M max-limit=10M name=wlan4-bulk packet-mark=wlan4-bulk parent=\
wlan4-qdisc priority=7 queue=default
add limit-at=1M max-limit=10M name=wlan4-fast packet-mark=wlan4-fast parent=\
wlan4-qdisc priority=2 queue=default
add limit-at=5M max-limit=40M name=wlan4-guifi packet-mark=wlan4-guifi \
parent=wlan4-qdisc priority=4 queue=default
add limit-at=3M max-limit=30M name=wlan4-interactive packet-mark=\
wlan4-interactive parent=wlan4-qdisc priority=1 queue=default
add limit-at=3M max-limit=30M name=wlan4-internet packet-mark=wlan4-internet \
parent=wlan4-qdisc priority=3 queue=default

Enquesta de satisfacció amb el servei de guifi.net

Bon dia

Des de Nicstudios i l’Associacio Guifi.net de Sant Feliu de Codines us demanem 5 minuts del vostre temps per omplir una enquesta, amb la qual volem analitzar el vostre grau de satisfaccio amb el servei de conexio a Internet a traves de guifi.net que oferim.
L’enquesta romandra oberta fins el dia 1 de maig.

Moltes gracies per la vostra participacio.